Corrigindo Erro do Pulse Audio no Debian

Uso o Debian Testing e o Pulseaudio não funcionava por aqui, o que me impedia de utilizar o Firefox normal (estava preso ao Firefox-esr, onde o som funcionava com o Alsa).

Pesquisei um bocado sobre isso e encontrei uma dica para resetar o Pulseaudio no site de suporte do Arch Linux.

Para isso, rode os dois comandos abaixo (o segundo como root/sudo):

$ rm -rf ~/.pulse* ~/.config/pulse
$ sudo rm -rf /tmp/pulse*

Depois disso recarregue o Pulseaudio e ele deve funcionar.

Comando para recarregar:

$ pulseaudio -D

Para ter certeza de que funcionou rode mais um comando:

$ systemctl --user status pulseaudio.*

A resposta deve, como a minha, conter: “Active: active (running)”. E a saída completa
será mais ou menos assim:

● pulseaudio.service - Sound Service
Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor pr
Active: active (running) since Tue 2018-08-07 02:17:20 -03; 16min ago
Main PID: 780 (pulseaudio)
CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.service
└─780 /usr/bin/pulseaudio --daemonize=no

● pulseaudio.socket - Sound System
Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; disabled; vendor pre
Active: active (running) since Tue 2018-08-07 02:15:40 -03; 18min ago
Listen: /run/user/1000/pulse/native (Stream)
CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.socket

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s