Ubuntu: corrigindo erro do pciehp (hot plug do pci-e)

De uns tempos para cá passei a receber o erro abaixo durante o boot do meu Ubuntu 14.04, devidamente atualizado.

[ 2050.615144] pciehp 0000:00:1c.5:pcie04: Card not present on Slot(0-2)
[ 2050.619104] pciehp 0000:00:1c.5:pcie04: Card present on Slot(0-2)

As linhas acima aparecem antes da tela de splash e se repetem indefinidamente, sendo que, algumas vezes, o erro se parece com isso:

pciehp 0000:00:1c.5:pcie04: Card not present on Slot(37)
pciehp 0000:00:1c.5:pcie04: Card present on Slot(37)
pciehp 0000:00:1c.5:pcie04: Link Training Error occurs
pciehp 0000:00:1c.5:pcie04: Failed to check link status

A repetição da informação de erro acaba inviabilizando o uso do terminal virtual (aquele que você pode acessar com “Ctrl + ALt + F1 até F6”), mas não o login gráfico, que tem seu desempenho prejudicado.

Depois de buscar muito, achei a solução que disponibilizo abaixo:

No terminal já aberto, rode:

sudo nano /etc/default/grub

Forneça sua senha de usuário e, no arquivo aberto, altere a linha que antes estava assim:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Deixando-a assim:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_ports=compat"

Salvando e fechando o editor.

Volte ao terminal e rode:

sudo update-grub

Reinicie o computador e veja se o erro sumiu (no meu caso, sumiu).

Anúncios

Sobre pinduvoz

Advogado por profissão, entusiasta do SL por opção.
Esse post foi publicado em Uncategorized e marcado , . Guardar link permanente.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s