Kernel 3.8 no Ubuntu 12.04-LTS

Já tinha ensinado aqui como instalar o Kernel do Quantal  (12.10) no Precise (12.04).

Se você não leu a dica anterior, siga o link:

Kernel 3.5 no Ubuntu 12.04-LTS

Agora vou ensinar como instalar o Kernel do Raring (13.04) no Precise, que é a versão do Ubuntu com maior suporte (vai até abril de 2017).

Ter o Kernel 3.8 no Ubuntu 12.04-LTS é, mais uma vez, tão fácil quanto “roubar doce de criança”, já que basta usar, no terminal (Ctrl + Alt + T), o comando abaixo:

sudo apt-get install linux-image-generic-lts-raring

Depois de reiniciar o sistema utilizando o kernel novo, instale os “headers” para ele se você costuma compilar código. Faça assim:

sudo apt-get install linux-headers-`uname -r`
(veja que são crases, uma antes e outra depois de “uname -r”)

Os Kernels 3.5 e 3.8 foram adicionados às “backports” (backport = porta-dos-fundos, ou entrada alternativa) do Ubuntu 12.04.2 por conta do suporte ao hardware ampliado e aprimorado, valendo a pena a troca em determinados casos.

About these ads

Sobre pinduvoz

Advogado por profissão, entusiasta do SL por opção.
Esse post foi publicado em Ubuntu e marcado , , , , , , , . Guardar link permanente.

6 respostas para Kernel 3.8 no Ubuntu 12.04-LTS

  1. André disse:

    Com o suporte a novos hardwares, o novo kernel resolve o problema (nesse caso, pessoal) de o Ubuntu 12.04 não reconhecer meu celular LG 615f? É um celular com android. Sei que o Ubuntu 13.04 reconhece, mas o 12.04, não.

  2. pinduvoz disse:

    Não, pois o problema com o Android é outro.
    E a solução é outra, ou seja, esta: http://va.mu/cUHr

  3. Dúvida de leigo: li que existem alguns kernels (o plural correto seria esse?) de longo suporte, que corrigem eventuais falhas de segurança. No caso de um kernel instalado da forma apresentada no artigo, a atualização seria automática?

    Abraços,
    Vitor

    • pinduvoz disse:

      O plural está correto, pois a palavrá não é portuguesa (se fosse, seria “Kernéis”).

      Os kernels que vêm por “backport” (atualização que inclui novas funcionalidades) também recebem atualizações automáticas de segurança, mas apenas pelo prazo de suporte da distribuição de que eles vêm.

      O Kernel 3.5, do Ubuntu 12.10, tem 18 meses de suporte, vencendo em abril/2014. E o 3.8, do Ubuntu 13.04, vencerá na mesma data, pois o prazo de suporte é de apenas um ano. Sendo assim, não será seguro usar 3.5 e 3.8 apenas a partir de abril/2014. Antes disso, é a mesma coisa que usar o kernel 3.2.

      Se vc está acostumado com o Ubuntu, já deve ter percebido que o kernel é o pacote que recebe mais atualizações de segurança. E isso vale tanto para o original quanto os do “backports”.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s